Back to overview
Downtime

Emergency Network Maintenance in NL Datacenter

Apr 28 at 03:59pm CEST
Affected services
Amsterdam, Nederland

Resolved
Apr 28 at 08:15pm CEST

Our local partner's teams at the Netherlands data center have made progress in resolving the issue.
We are currently working on finalizing the fixes and bringing systems back online.
We will post an update once the work is completed.

Updated
Apr 28 at 06:13pm CEST

Netherlands is still experiencing a power supply disruptions. Our local partner's technical teams at the data center are actively working to restore power. We will keep you updated as soon as new information becomes available.

Updated
Apr 28 at 05:13pm CEST

Identified - Due to ongoing power issues affecting the Netherlands data center, a number of services — including Web Hosting, VPS, and email — are currently impacted. Our technical teams are actively working with local partners to restore power and ensure service continuity as quickly as possible.
We sincerely apologize for the inconvenience and appreciate your patience.

Created
Apr 28 at 03:59pm CEST

We are performing an emergency Network maintenance in the Netherlands datacenter. Client websites hosted there could be temporarily inaccessible or might load slower than usual. Our team is currently working to restore normal performance levels. We apologize for any inconvenience caused.